Einleitung

 Einleitung: (HelpVersion: 2.2.45)

Was ist XSubst?
  • Damit lassen sich beliebige Verzeichnisse als Laufwerke ansprechen. Dies entspricht dem seit DOS-Zeiten bekannten Befehl SUBST, jedoch ist XSubst keine Windows GUI für diesen DOS-Befehl, sondern eine reine Windows-Anwendung.
  • Es zeigt übersichtlich alle Laufwerke und ihre Zuordnungen wie z.B. Netz-Laufwerke und deren Pfade oder eben Subst-Laufwerke mit Pfade oder auch CD-ROMs, Wechseldatenträger usw.
  • Subst-Laufwerke können ausserdem entweder temporär oder permanent eingerichtet werden.
Es bietet auch Komfortfunktionen wie z.B.
  • Laufwerke automatisch permanent anlegen.
  • Ändern des Pfades eines Subst- oder Netz-Laufwerkes ohne es vorher umständlich trennen zu müssen.
  • Wandlung eines Subst-Laufwerkes in ein Netz-Laufwerk oder umgekehrt in einem Arbeitsgang.
  • Neuverbinden von inaktiven Subst-Laufwerken.
  • Anlegen von Laufwerks-Verknüpfungen auf dem Desktop automatisch oder manuell.
  • Ab V1.0.80 können nun auch Netz-Laufwerke verwaltet werden. Dies ist jedoch ein Bonus-Feature und es stehen nicht alle Funktionen der Subst-Laufwerke zur Verfügung.
  • Bietet seit V1.5 Multiuser-Support. Die Konfiguration wird für jeden Windowsbenutzer separat verwaltet.
  • Ab V1.6 stehen die wichtigsten Funktionen ({Verbinden}/{Trennen}) optional auch als Shell Kontext Erweiterung im Arbeitsplatz/Explorer zur Verfügung.
  • Seit V2.0 gibt es nun auch Multilanguage-Support. Über sogenannte Language Packs kann XSubst prinzipiell in jede auf lateinischem Alphabet basierende Sprache übersetzt werden.
Was ist es nicht? (Beschränkungen)
  • XSubst ist kein CD-ROM-Emulator. Es kann also solche Programme wie Daemon-Tools nicht ersetzen. Es ermöglicht den komfortablen Umgang mit Subst-Laufwerken ohne dafür das DOS-Pendant SUBST heranziehen zu müssen. Nicht mehr und nicht weniger.
  • Die Verwaltung von Netz-Laufwerken unterliegt den Regeln von XSubst. Es können also nur Netz-Laufwerke auf Freigaben eingerichtet werden, für die der aktuelle User auch die Rechte hat. Die Verwaltung der Netz-Laufwerke ist als Bonus zu sehen, die Hauptaufgabe von XSubst ist und bleibt die Verwaltung von Subst-Laufwerken.
  • XSubst ist nicht batchfähig sondern konsequent auf GUI ausgelegt. Ich sehe schlicht keinen Sinn darin es batchfähig zu machen, da XSubst genau deswegen entwickelt wurde, um Subst-Laufwerke bequem über Windows einrichten zu können. Wer eine batchfähige Alternative sucht, sollte sich vSubst anschauen.
  • Nicht kompatibel mit Win 95! Für diese Windows Variante müsste ich sehr vieles in XSubst umbauen/erweitern da Win 95 keine API für Subst-Laufwerke bietet. Win 98 ist Mindestvoraussetzung.
Hinweise zu dieser Hilfe
  • Die Bereiche dieser Hilfe können Kontextabhängig über <F1> abgerufen werden. Befindet man sich z.B. in der Konfiguration und drückt <F1>, erscheint der Abschnitt "Konfiguration" der Hilfe.
  • Funktionen die sich auf die Tastatur beziehen, sind mit spitzen Klammern gekennzeichnet. Beispiel: <Return>.
  • Funktionen die sich auf Buttons oder Funktionen von XSubst beziehen, werden in geschweiften Klammern dargestellt. Beispiel: {Ändern}
  • Tipps werden so dargestellt.
  • Wichtige Hinweise werden so dargestellt.
Gewährleistung
Dieses Programm wird so wie es ist ("as is") ausgeliefert. Der Autor gibt keine Garantie bezüglich der korrekten Funktion dieses Programmes, ebenso wird für eventuell durch dieses Programm verursachte Schäden keine Haftung übernommen. Installation und Benutzung erfolgt auf eigenes Risiko!

Auch für eventuelle Überschwemmungen, Erdbeben, formatierte Festplatten, durchgebrannte Netzteile und ähnliches kann der Autor nicht haftbar gemacht werden. Des weiteren ist es auch nicht das Verschulden des Autors, wenn Sie durch Benutzung dieses Programmes den Goldhamster ihrer Nachbarin zur Explosion bringen. Auch die Aussage einiger Leute, dass dieses Programm das Stromnetz ganzer Stadtteile lahm gelegt hat, ist ein Gerücht und wurde nie offiziell bestätigt.

Lizenz
Dieses Programm ist prinzipiell Freeware und darf sowohl in privaten wie auch in kommerziellen Umgebungen kostenlos eingesetzt werden. Es ist erlaubt, dieses Programm in vollständigem und unverändertem Zustand auf Webseiten zum Download anzubieten. Es ist erlaubt, dieses Programm in vollständigem und unverändertem Zustand auf Datenträgern wie CD und DVD (als kostenlose Beigabe) anzubieten. Es ist nicht erlaubt, für die explizite Bereitstellung dieses Programmes Geld zu verlangen! Es ist nicht erlaubt, dieses Programm in irgendeiner Form zu modifizieren!

Spende:
XSubst ist und bleibt Freeware. Wem jedoch XSubst eine Spende wert wäre, den möchte ich nicht aufhalten. ;) Wer mir eine Spende zukommen lassen möchte, dem teile ich per EMail meine Kontodaten mit.


Bedienung

 Bedienung:

Allgemein:

Die Einrichtung von Subst- und auch Netzlaufwerken erfolgt denkbar einfach: Zuerst wird das gewünschte Laufwerk ausgewählt und dann {Verbinden} geklickt. Anschliessend kann der gewünschte Pfad ausgewählt werden. Dies kann sowohl ein lokaler Pfad, als auch eine Netzwerk-Freigabe sein. Es wird dann automatisch entweder ein Subst- oder ein Netz-Laufwerk angelegt. Mit {Trennen} kann das jeweilige Laufwerk wieder dauerhaft entfernt werden. Alle Funktionen gelten sowohl für Subst- als auch Netz-Laufwerke, sind in der Bedienung also identisch. Es wird übrigens in jeder Situation geprüft, ob eine Funktion gerade möglich ist oder nicht und dementsprechend werden Buttons aktiviert oder deaktiviert. Es ist also nicht möglich irgendwelche Aktionen durchzuführen, die völlig sinnfrei wären.

Die LED-Leiste: (falls aktiviert)
Über verschiedenfarbige LED's lässt sich schnell und übersichtlich der Zustand jedes Laufwerks erkennen.

Die Farben haben dabei folgende Bedeutung:

= Ein Standard Windows-Laufwerk welches von XSubst nicht verwaltet werden kann. Zum Beispiel eine lokale Festplatte oder ein CD-ROM.
 = Das ist spezieller Zustand den es nur in XSubst gibt. Hierbei handelt es sich um ein permanent eingerichtetes aber momentan inaktives Subst- oder Netz-Laufwerk dessen Laufwerks-Buchstabe von einem echten Datenträger wie z.B. einem USB-Stick überlagert wird.
 = Ein freier Laufwerks-Buchstabe. Darauf kann ein Subst- oder Netz-Laufwerk eingerichtet werden.
= Ein aktives Subst- oder Netz-Laufwerk.
= Ein inaktives Subst- oder Netz-Laufwerk. Dies gilt sowohl für permanent als auch temporär deaktivierte Laufwerke.

Die einzelnen Spalten der Laufwerksliste:
 Die Reihenfolge der Spalten sowie die Fensterbreite lässt sich übrigens ändern, wenn die Funktion {Spaltenpositionen und Fensterbreite änderbar} aktiviert wurde. Um eine Spalte an einer anderen Position zu platzieren, genügt es den Spaltenkopf mit der linken Maustaste an die neue Position zu verschieben.

Laufwerk:
Hier werden prinzipiell alle verfügbaren Laufwerke von A-Z angezeigt. Hinter den Laufwerks-Buchstaben werden die Laufwerks-Bezeichnungen (Labels) angezeigt, jedoch nur ab Laufwerk C. Per Tweak kann jedoch auch A und B angezeigt werden. Umgekehrt kann ebenfalls per Tweak die Anzeige der Labels komplett unterbunden werden.

Permanent:
Zeigt an, ob ein Laufwerk nur für die Dauer einer Windows Sitzung existiert, oder auch nach einem Neustart. Ist der Eintrag beim jeweiligen Laufwerk leer, gilt die Zurodnung nur für die aktuelle Sitzung. Steht dort ein "Ja", ist es ein permanent angelegtes Laufwerk, existiert also auch nach einem Neustart noch. Wird das Laufwerk als "Deaktiviert" ausgewiesen, handelt es sich um ein dauerhaft deaktiviertes Subst-Laufwerk.

Typ:
Zeigt an um welchen Typ es sich bei dem Laufwerk handelt, wie z.B. CD-Rom, Festplatte, Subst-Laufwerk usw. Hinter dem Typ werden in Klammen manchmal noch sekundäre Informationen angezeigt, z.B. ob ein Subst-Laufwerk mit einer Festplatte oder einem Wechseldatenträger verbunden ist, oder ob das Subst-Laufwerk oder Netz-Laufwerk gerade inaktiv ist.

Pfad:
Hier wird der Pfad angegeben, mit dem ein Laufwerk tatsächlich verbunden ist. Bei einem Subst-Laufwerk wird der Pfad zu einem lokalen Verzeichnis angezeigt und bei einem Netz-Laufwerk entsprechend der UNC-Pfad.

Die Statusbar:
Unten im Hauptfenster informiert die Statusbar über einige Infos.

Benutzer:
Zeigt den Loginnamen des aktuellen Windows Benutzers. Alle Daten werden benutzerspezifisch verwaltet. Es sei denn es wurde per Tweak die globale Verwaltung aktiviert, dann steht hier <Global>.

INI:
Dieser Indikator zeigt an ob die benutzerspezifische INI verwendet wird, oder die zentrale (globale) INI. Dementsprechend steht hier <Benutzer> oder <Global>.

Autostart:
Zeigt jederzeit aktuell an, ob XSubst beim nächsten Windows Neustart ebenfalls gestartet wird oder nicht. Dies ist abhängig von der Konfiguration und/oder ob mindestens ein aktives permanentes Subst-Laufwerk vorhanden ist.

Funktionsumfang:
Ist XSubst auf einer lokalen Platte installiert, ist der vollständige Funktionsumfang gegeben und hier steht "Vollständig". Wird es jedoch z.B. von einem USB-Stick gestartet, gibt es einige Einschränkungen und hier steht dann "Eingeschränkt". (Siehe Anhang/Technische Details/Installation auf USB-Stick)

Die Bereitschafts-LED:
Über den Buttons gibt eine zweifarbige LED (rot/grün) darüber Auskunft, ob XSubst gerade beschäftigt oder bereit für Benutzereingaben ist. Das ist vor allem bei Aktionen sinnvoll die etwas länger dauern können. z.B. bei der Reaktivierung eines deaktivierten Netz-Laufwerkes. Gleichzeitig wird damit auch angezeigt, ob die Benutzeroberfläche von XSubst gesperrt oder frei ist.

Unterschiede der Funktionen bei Subst- und Netz-Laufwerken:
Prinzipiell sind die wichtigsten Funktionen für beide Laufwerkstypen identisch in der Bedienung und den Möglichkeiten. Trotzdem gibt es natürlich Unterschiede, da ein Subst-Laufwerk nunmal etwas anderes als ein Netz-Laufwerk ist:

1.) Die Funktion für temporäres {Deaktivieren} steht nur bei Subst-Laufwerken zur Verfügung.
2.) Der Status {Permanent}/{Temporär} kann bei Subst-Laufwerken geändert werden, ohne die Verbindung trennen zu müssen. Dies ist bei Netz-Laufwerken nicht möglich.

Betrachten wir nun die einzelnen Funktionen genauer:

Funktionen:

Manche Buttons sind doppelt belegt und wechseln je nach Situation zwischen zwei verschiedenen Funktionen.

Tipp: Um Funktionen auch ohne Maus bedienen zu können, besitzt jeder Button einen Shortcut. Dieser wird aufgerufen mit <Alt> plus dem unterstrichenen Buchstaben. Also lässt sich z.B. {Verbinden} auch mit <Alt>+<v> erreichen.

Tipp2: Die Shortcuts lassen sich übrigens im jeweiligen Language Pack ändern.

Verbinden/Ändern:

Verbinden:
Damit können sowohl Subst- als auch Netz-Laufwerke angelegt werden. Explizit auswählen muss man dies jedoch nicht, XSubst weiss anhand der Pfad-Struktur selbst, welcher Laufwerks-Typ anzulegen ist. In der Ordner-Auswahl wird einfach der Pfad ausgewählt und mit {OK} bestätigt.

Ändern:
Hinter diesem einfach klingenden Wort, steckt tatsächlich eine recht aufwendige Funktion die sehr viel Komfort bietet. Dieser Komfort ist mit den Bordmitteln von Windows selbst so gar nicht möglich. Die wichtigste Funktion ist natürlich das ändern des Pfades eines Laufwerkes. Dabei spielt es keine Rolle, ob dies ein Subst- oder ein Netzlaufwerk ist. Die Bedienung ist der Funktion {Verbinden} sehr ähnlich: Es erscheint der Requester für die Ordner-Auswahl. Nachdem wieder mit {OK} bestätigt wurde, wird der Pfad des gewählten Laufwerkes geändert ohne das eine vorherige Trennung und Neueinrichtung nötig wäre. Möglich ist damit auch die direkte Wandlung eines Subst-Laufwerkes zu einem Netz-Laufwerk oder umgekehrt.

Laufwerks-Buchstabe ändern per Drag&Drop:
Genauso einfach wie sich der Pfad eines Laufwerkes ändern lässt, kann einem Pfad auch ein anderer Laufwerks-Buchstabe zugewiesen werden. Hierzu einfach per Maus den betreffenden Eintrag mit der linken Maustaste auf das gewünschte freie Laufwerk ziehen und loslassen. Alle aktiven Zustände und Einstellungen des Laufwerks werden übernommen.

Permanent/Temporär:

Permanent:
Soll ein Laufwerk beim nächsten Start von Windows wieder verfügbar sein, kann mit diesem Button das Laufwerk auf permanent gesetzt werden. Diese Funktion steht für Subst-Laufwerke nur zur Verfügung, wenn XSubst von einer lokalen Festplatte gestartet wurde.

Tipp: In der Konfiguration kann festgelegt werden, ob neue Laufwerke automatisch permanent angelegt werden sollen. (Siehe Konfiguration)

Temporär:
Natürlich lässt sich dann auch umgekehrt ein permanentes Laufwerk wieder als temporäres definieren, ist also beim Neustart nicht mehr vorhanden.

Aktivieren/Deaktivieren:

Aktivieren:
Diese Funktion ist dann nützlich, wenn z.B. beim Windows-Start ein Subst-Laufwerk auf eine externe Platte nicht eingerichtet werden konnte, weil diese nach dem Neustart noch gar nicht angeschlossen war. In diesem Fall genügt nach dem anschliessen der Platte ein Klick auf diese Funktion. Damit kann die erneute Einrichtung des Laufwerkes vermieden werden. Diese Funktion kann aber auch verwendet werden, um ein permament deaktiviertes Subst- oder Netz-Laufwerk wieder zu aktivieren.

Deaktivieren:
Damit kann ein permanentes Subst-Laufwerk temporär deaktiviert (getrennt) werden, ohne den Eintrag ganz zu löschen. Das Laufwerk wird also für die Dauer der Sitzung getrennt und steht nach einem Neustart wieder zur Verfügung.

Perm. deakt. (Permanent deaktivieren)
Im Prinzip gilt hier das gleiche wie bei {Deaktivieren}, jedoch wird das Laufwerk beim Neustart nicht mehr eingerichtet. Praktisch wenn man ein Laufwerk erstmal nicht mehr braucht, den Eintrag aber nicht löschen möchte. Diese Funktion steht auch für Netz-Laufwerke zur Verfügung.

Trennen:
Das Gegenstück zu {Verbinden}. Mit dieser Funktion wird ein Subst- oder Netz-Laufwerk definitiv und endgültig getrennt (entfernt) und ist damit auch nach einem Neustart nicht mehr verfügbar.

Auf Desktop:
Erzeugt eine Verknüpfung des gerade gewählten Laufwerkes direkt auf dem Desktop. Bevor die Verknüpfung angelegt wird, kann natürlich der Name der Verknüpfung noch angepasst werden. Im Kommentar der Verknüpfung wird ausserdem automatisch der Pfad des Laufwerkes eingetragen, welcher unter W2K und XP als Tooltip zur Verknüpfung erscheint.

Tipp: Bei neu angelegten permanenten Laufwerken lässt sich das auch automatisieren. (Siehe Konfiguration)

Kontextmenü Erweiterung (SKE):

Die wichtigsten Funktionen {Verbinden} und {Trennen} lassen sich optional auch über den Arbeitsplatz und Datei-Explorer direkt aufrufen ohne dazu XSubst starten zu müssen. Um ein Subst- oder Netz-Laufwerk anzulegen, genügt ein Rechtsklick auf ein Verzeichnis und die Auswahl von "XSubst - Laufwerk verbinden...". Dann erscheint eine Liste der verfügbaren Laufwerks-Buchstaben. Wird das Kontextmenü eines Laufwerkes im Arbeitsplatz aufgerufen, findet sich dort der Eintrag "XSubst - Laufwerk trennen" womit dieses wieder entfernt werden kann, sofern es ein gültiges Subst- oder Netz-Laufwerk ist. Die Erweiterung muss in der Konfiguration erst aktiviert werden. Die Erweiterung hält sich übrigens an die Regeln die in der Konfiguration unter "Benutzer Laufwerke/Kontextmenü Erweiterung" festgelegt wurden.

 Übrigens wird bei der Funktion Verbinden über die SKE überprüft, ob es den angegebenen Pfad auch wirklich gibt. Diese Überprüfung findet sowohl bei lokalen als auch bei Netzwerk-Pfaden statt. Wenn also die Liste der verfügbaren Laufwerks-Buchstaben erscheint, ist der Pfad auch gültig. Ansonsten erscheint die Liste erst gar nicht. Diese Überprüfung ist zwingend notwendig da über die Erweiterung prinzipiell ja auch völliger Nonsens übergeben werden könnte. Und wenn diese Prüfung nicht stattfände, könnte mit XSubst trotzdem ein Laufwerk darauf angelegt werden und somit zumindest kurzfristig Windows ziemlich "irritieren". ;) Darum ist es über die SKE leider nicht möglich, Netz-Laufwerke auf freigegebene Wechseldatenträger einzurichten in denen kein Medium eingelegt ist, z.B. auf ein freigegebenes CD-ROM in das keine CD eingelegt ist.

Tipp: Die SKE lässt sich übrigens auch dazu verwenden um die Grundfunktionen in andere Anwendungen zu integrieren, z.B. in einen Datei Manager eines Drittherstellers, sofern dieser eine Schnittstelle für externe Programme hat. (Siehe Anhang/Integration in andere Programme)

Hinweis: Wird unter Win98/WinME über den Explorer ein Subst-Laufwerk entfernt, kann es sein das der Explorer die Anzeige nicht korrekt aktualisiert. In diesem Fall hilft <F5>.

Sonstige Funktionen:

STRG+P:
Wechselt zwischen 3 verschiedenen Pfad-Anzeigetypen. Der letzte Anzeigetyp wird gespeichert. Ist der Anzeigetyp ungleich 1, wird dieser in Klammern in der Pfad-Spalte angezeigt.

1) Bei Subst- und Netz-Laufwerken werden die normalen Pfade angezeigt. (Standard)
2) Bei aktiven Laufwerken die weder Subst- noch Netz-Laufwerke sind, werden die NT Gerätenamen/Pfade angezeigt.
3) Bei allen aktiven Laufwerken werden die NT Gerätenamen/Pfade angezeigt.

Hinweis: Setzt Windows mit NT Kernel voraus. Unter Win98/WinME ist diese Funktion deaktiviert.

STRG+D:
Zeigt Debuginfos an die im Problemfall wichtige Informationen liefern können. Ausserdem wird hier der Inhalt der aktiven Konfigurationsdatei (INI) gelistet. Wird in der normalen Praxis nicht benötigt.

F5:
Normalerweise löst XSubst automatisch eine Aktualisierung der Laufwerksliste aus, sobald eine Veränderung an den Laufwerken festgestellt wird. Mit dieser Funktion kann jedoch auch eine manuelle Aktualisierung ausgeführt werden.


Konfiguration

 Konfiguration:
Alle Änderungen im Konfigurationsfenster werden sofort übernommen. Prinzpiell wird unterschieden zwischen Benutzer-Einstellungen und globalen Einstellungen.

Registerkarte Benutzer Einstellungen

Diese Einstellungen werden Benutzerspezifisch verwaltet, gelten also individuell für jedes Windows Benutzerprofil.

Allgemein

Spaltenpositionen und Fensterbreite änderbar:
Ist dieser Schalter aktiviert, lässt sich sowohl das Haupt-Fenster in der Breite anpassen, als auch die Positionen der Spalten. Weiterhin wird in diesem Modus auch die Spaltenbreite der einzelnen Spalten dauerhaft gespeichert.

Rasterlinien anzeigen:
Legt ein Gitter über die Laufwerks-Liste. Wer es lieber "klassisch" mag wie in früheren Versionen von XSubst, kann dies auch abschalten.

LED's anzeigen:
Signalisiert über eine LED-Leiste den Zustand/Typ jedes Laufwerks. Mehr dazu unter Bedienung.

In Systray minimieren:
Wer XSubst lieber in den Systray (Bereich in der Taskleiste neben der Uhr) minimieren möchte, aktiviert diesen Schalter. Mit Linksklick auf das Systray-Icon kann XSubst wiederhergestellt werden. Mit Rechtsklick wird ein kleines Kontextmenü mit den nötigsten Funktionen eingeblendet. In Kombination mit einer der nächsten beiden Optionen wird XSubst beim Windows Neustart direkt in den Systray minimiert.

Bleibt geladen, falls mit Windows gestartet:
Normalerweise wird XSubst nur dann mit Windows geladen, wenn es mindestens ein Subst-Laufwerk einzurichten gibt. Danach wird XSubst sofort wieder beendet. Ist aber dieser Schalter gesetzt und XSubst wird beim nächsten Neustart von Windows geladen weil es ein Laufwerk einzurichten gibt, bleibt XSubst geladen.

Wird prinzipiell geladen wenn Windows startet:
Ist dieser Schalter aktiviert, wird XSubst auf jeden Fall geladen, egal ob es Laufwerke einzurichten gibt oder nicht. Aktiviert auch automatisch {Bleibt geladen, falls mit Windows gestartet}.

Hinweis: Sowohl dieser als auch der vorige Schalter dient nicht dazu, um permanente Subst-Laufwerke beim Windowsstart wieder einzurichten, darum kümmert sich XSubst schon selbst. Diese beiden Schalter regeln lediglich das Verhalten von XSubst nach dem Windowsstart.

Von letzter Position starten:
Normalerweise startet XSubst immer zentriert, bezogen auf den gesamten Bildschirm. Ist dieser Schalter aktiv, wird die letzte Position gespeichert und von dieser wieder gestartet. Dies ist z.B. für Multimonitor-Betrieb interessant.

 Hinweise anzeigen:
Bei manchen Funktionen werden Hinweise angezeigt die weitere Infos liefern oder auf mögliche Probleme hinweisen. Wird ein Hinweis per Haken deaktiviert, wird er nicht mehr angezeigt. Mit diesem Schalter lassen sich die Hinweise entweder alle deaktivieren oder wieder aktivieren. Befindet sich der Schalter im Zwischenzustand (Ghosted), gibt es sowohl aktivierte als auch deaktivierte Hinweise. Bei diesen Hinweisen handelt es sich übrigens nicht um die üblichen "Wussten Sie schon..." Tipps, sondern um wichtige Infos und es wird empfohlen diese erstmal aktiviert zu lassen.

Sprache/Language/Langue/Lengua/Lingua

Hier kann eines der verfügbaren Language Packs ausgewählt werden. Dieses wird dann sofort geladen ohne das ein Neustart von XSubst nötig wäre. Gibt es zu einem Languagepack auch eine entsprechende Übersetzung der Onlinehilfe, wird diese automatisch aktiviert und steht per Menü (oder F1) zur Verfügung.

Registerkarte Benutzer Laufwerke

Diese Einstellungen werden Benutzerspezifisch verwaltet, gelten also individuell für jedes Windows Benutzerprofil.

XSubst Oberfläche

Diese Einstellungen beziehen sich nur auf Laufwerke, die über die Oberfläche (GUI) von XSubst eingerichtet werden.

Warnhinweise bei Laufwerks-Trennungen:
Wenn aktiviert, werden Warnhinweise angezeigt die bestätigt werden müssen. Diese erscheinen immer dann, wenn bei einer Aktion das gewählte Laufwerk kurz oder dauerhaft getrennt werden muss. Dies dient als "Sicherung" um Datenverlust vorzubeugen. Es empfiehlt sich diesen Schalter aktiviert zu lassen, wenn man mit XSubst noch nicht vertraut ist. Wer jedoch genau weiss was XSubst tut, kann diesen Schalter auch deaktivieren. Dann werden alternativ zu den Warnhinweisen die entsprechenden Buttons je nach Situation mit einer roten Hintergundfarbe markiert. Dies dient als Indikator dafür, dass beim drücken des jeweiligen Buttons eine Trennung erfolgt. Ist also sozusagen der Expertenmodus.

Subst-Laufwerke

Laufwerke automatisch permanent anlegen:
Damit werden neu angelegte Subst-Laufwerke gleich als permanent angelegt, werden also beim Windows-Start automatisch wieder eingerichtet.

Automatisch Verknüpfung auf Desktop anlegen:
Beim anlegen eines Laufwerkes, wird automatisch eine Verknüpfung zu diesem Laufwerk auf dem Desktop erzeugt. Im Kommentar der Verknüpfung wird ausserdem der Pfad des Laufwerkes eingetragen, welcher unter W2K und XP als Tooltip zur Verknüpfung erscheint. Da dieser Automatismus nur dann Sinn macht, wenn es sich um permanente Laufwerke handelt, ist er an die Option {Laufwerke automatisch permanent anlegen} gebunden.

Netz-Laufwerke

Laufwerke automatisch permanent anlegen:
Gleiche Funktion wie unter "Subst-Laufwerke" beschrieben.

Automatisch Verknüpfung auf Desktop anlegen:
Gleiche Funktion wie unter "Subst-Laufwerke" beschrieben.

Kontextmenü Erweiterung

Diese Einstellungen beziehen sich nur auf die Laufwerke, die über die Shell Kontext Erweiterung (SKE) von XSubst eingerichtet werden. Das gilt für die Integration in den Arbeitsplatz/Explorer als auch für leistungsfähige Dateimanager wie dem Total Commander.

Warnhinweise bei Laufwerks-Trennungen:
Im Prinzip gilt hier das gleiche wie unter "XSubst Oberfläche" beschrieben, jedoch nur für Laufwerke die über die SKE getrennt werden.

Subst-Laufwerke:

Gleiche Funktionen wie unter "XSubst Oberfläche/Subst-Laufwerke" beschrieben.

Netz-Laufwerke

Gleiche Funktionen wie unter "XSubst Oberfläche/Subst-Laufwerke" beschrieben.

Registerkarte Global

Diese Einstellungen werden global verwaltet, sind also unabhängig vom jeweiligen Windows Benutzerprofil.

Kontextmenü Erweiterung

Registriere Kontextmenü Erweiterung:
Wenn dieser Schalter gesetzt ist, werden die Standardfunktionen {Verbinden}/{Trennen} direkt im Kontextmenü von Arbeitsplatz und Explorer integriert. Damit lässt sich sehr einfach ein Subst-Laufwerk auf ein Verzeichnis anlegen und auch wieder entfernen. Für diese Funktionalität müssen durch XSubst verschiedene Schlüssel und Werte in die Registry eingetragen werden, mehr dazu unter Anhang/Technische Details/Speicherung der Konfiguration. Wird die Shell Erweiterung nicht mehr benötigt, einfach den Haken entfernen.

Hinweis: Für die Einrichtung der Erweiterung unter Win2K/WinXP wird ein Administratorkonto benötigt.


Autor und Homepage

 Autor und Homepage:

Autor:
Luke Filewalker
E-Mail: lukefilewalker@gmx.net
Forum: forums.gateway-to-hell.com

Download:
Hauptseite: gateway-to-hell.com

Übersetzungen der Hilfe:
English (die wichtigsten Kapitel): DBH64 (dbh64@gmx.de)

Language Packs:
English: Icfu (icfu@gmx.de)
Francais: Fonetix (fonetic@freenet.de)
Deutsch: Ich selbst


Credits

 Credits:

Danke an alle Betatester und Benutzer die durch ihre Bugreports und Ideen zur Verbesserung von XSubst beigetragen haben.

Special greetings goes to

gresti
Icfu
DBH64
Fonetic

Thx for your help and/or good ideas! :-)


FAQ

 FAQ:

Frage(1): Beim Starten von XSubst bekomme ich diese Fehlermeldung: "run-time error '339': MSCOMCTL.OCX missing"
Antwort: XSubst verwendet die ListView-Komponente dieser ActiveX Control DLL. Fehlt sie oder ist nicht registriert, erscheint diese Fehlermeldung. Man kann die Datei entweder manuell in das Verzeichnis \windows\system32 (bzw. \windows\system unter 9x) kopieren und mit regsvr32 registrieren, oder aber man überlässt diese Arbeit meinem "MSCOMCTLOCXupdater" der von GTH heruntergeladen werden kann. Einfach starten, der Rest ist selbsterklärend. Die dritte Möglichkeit wäre die Installation von "Allgemeine Steuerelemente von Microsoft Visual Basic 6.0". Hier wird neben der ActiveX DLL COMCTL32.OCX auch die besagte MSCOMCTL.OCX in der korrekten Version installiert.

Frage(2): Wenn ich versuche die Spalten anders anzuordnen, verabschiedet sich XSubst einfach so, ohne eine Fehlermeldung anzuzeigen.
Antwort: Dieser CTD (Crash To Desktop) wird nicht durch XSubst erzeugt, sondern durch einen Bug im Drag&Drop der MSCOMCTL.OCX von Microsoft. In diesem Fall sollte mein MSCOMCTLOCXupdater (Siehe Antwort zu Frage 1) verwendet werden, um diese Bibliothek zu aktualisieren. Ab der Version 6.1.97.86 wurde dieser Bug behoben und nach dem Update sollte das Drag&Drop der Spalten einwandfrei funktionieren.

Frage(3): Ich habe zwei Monitore und ich würde XSubst gerne auf dem sekundären Monitor starten, geht das?
Antwort: Das ist möglich. Normalerweise startet XSubst zentriert auf dem primären Monitor. Seit V2.0 gibt es jedoch die Möglichkeit an beliebiger Position auf einem beliebigen Monitor zu starten. Aktiviert wird diese Funktion unter Datei/Konfiguration/Benutzer Einstellungen/Allgemein/Von letzter Position starten. Wie der Schalter schon vermuten lässt, merkt sich XSubst damit die letzte Position und startet wieder von dieser.

Frage(4): Ich möchte Programme in der Autostartgruppe einrichten, die sich bereits auf Subst-Laufwerke beziehen. Leider sind diese Substs beim Windows-Start noch nicht vorhanden, wieso?
Antwort: Das hängt damit zusammen, dass XSubst beim booten von Windows vom Benutzer abhängig ist. Da es also erst dann gestartet wird wenn sich der Benutzer anmeldet, kann es durchaus sein, dass während dem Start von Windows andere Programme noch nicht auf die Subst-Laufwerke zugreifen können. Prinzipiell könnte man dies über einen echten Dienst lösen. Allerdings hätte dieser den Nachteil, dass Konfiguration und Laufwerke dann nicht mehr Benutzerabhängig wären, sondern global. Der nächste Nachteil ist, dass ich unter 9x keine "echten" Dienste realisieren kann wie unter NT. Und eine der Bedingungen bei der Entwicklung von XSubst war, dass nur Funktionen eingebaut werden, die in jedem Windows (ab Win 98 aufwärts) funktionieren und realisiert werden können.


Technisches

 Technisches:

Windows Kompatibilität:
Es muss mindestens Windows 98 installiert sein, Windows 95 wird nicht unterstützt! Getestet wurde XSubst mit Windows 98, Windows 2000 und XP Pro. Zu anderen Windows-Varianten kann ich keine Angaben machen, da ich XSubst nur auf den genannten Betriebssystemen testen kann.

Nachtrag: XSubst ist definitiv nicht kompatibel zu Windows 95, da hier offenbar keine APIs zur Verwaltung von Subst-Laufwerken existieren.

 Technische Voraussetzungen:
Neben den VisualBasic-Runtimes (frei erhältlich) wird noch die ActiveX Control DLL mscomctlocx.ocx benötigt (frei erhältlich). Diese kann auch sehr einfach mit meinem MSCOMCTLOCXupdater nachinstalliert, bzw. zum updaten einer alten Version verwendet werden.

Installation:
Seit V1.0.63 wird XSubst mit Installer ausgeliefert, trotzdem ist nach wie vor keine Installation nötig. Der Installer hilft lediglich dabei die Dinge zu automatisieren, die man sonst manuell tun müsste. Also Ordner anlegen, Verknüpfungen erstellen usw. Im übrigen kann man XSubst wie bisher auch einfach nur entpacken und alles weitere selbst einrichten. Dazu müssen im Installer alle optionalen Punkte abgewählt werden, dann werden lediglich die Haupkomponenten in ein wählbares Verzeichnis entpackt ohne weitere Änderungen am System.

Um die volle Funktionalität von XSubst zu gewährleisten, muss xsubst.exe auf einer lokalen Festplatte (kein USB-Wechseldatenträger!) installiert sein, damit Windows beim Neustart darauf zugreifen kann.

Installation auf USB-Stick:
Prinzipiell kann XSubst auch von USB-Stick gestartet werden. Hierbei ist jedoch folgendes zu beachten:
  • Die Option {Permanent}/{Temporär} bei Subst-Laufwerken kann nicht geändert werden.
  • Es kann nichts am Startverhalten von XSubst bez. Windows-Neustart geändert werden.
  • Wird bei einem permanenten Subst-Laufwerk der Pfad geändert, wird es auf Temporär gesetzt.
  • Die Shell Kontext Erweiterung kann weder aktiviert noch deaktiviert werden.
  • Einige Optionen in der Konfiguration sind nicht verfügbar.
Hinweis: Bei Verwendung von USB Stick sollte die zentrale Verwaltung der INI aktiviert werden! (Siehe Anhang/Tweaks)

Folgende Dateien sind das Minimum um XSubst von USB-Stick verwenden zu können:
xsubst.exe (Hauptkomponente)
xsubst.ini

Optional:
xsubstshell.exe (wird nur unter 98/ME für Integration z.B. in TC benötigt, gehört zur SKE)
mxscomctl.ocx (wenn vorhanden, muss diese Datei nicht lokal auf dem PC installiert sein)
helpfiles\ (Ordner enthält die Online HTML Hilfedateien)
languages\ (Ordner enthält die Sprachdateien)

Speicherung der Konfiguration:
Alle Daten werden in einer Textdatei (xsubst.ini) gespeichert.

Der Pfad zur INI lautet, falls persönliche Verwaltung (Standard) aktiv ist:
%userprofile%\anwendungsdaten\luke filewalker productions\xsubst

Der Pfad zur INI lautet, falls zentrale Verwaltung (Siehe Tweaks) aktiv ist:
<xsubst ordner>\xsubst.ini
Ist die Shell Kontext Erweiterung aktiv, sind ausserdem in folgenden Registry-Pfaden Informationen gespeichert:

 HKEY_LOCAL_MACHINE\Software\Luke Filewalker Productions\XSubst
HKEY_CLASSES_ROOT\Directory\shell
 HKEY_CLASSES_ROOT\drive\shell

Hinweis: Viele Einstellungen von XSubst in der Registry sind von anderen abhängig und man sollte manuelles Eingreifen in die Konfiguration mittels Regedit vermeiden! Tweaks sind die einzige Ausnahme. Das gleiche gilt natürlich auch für die INI. Manuelle Änderungen sollte man nur dann vornehmen, wenn man genau weiss, wie alle Einstellungen zusammenhängen.

Papierkorb und Subst-Laufwerke:
Mir fiel ein merkwürdiges Verhalten des Papierkorbs auf. Dies betrifft Subst-Laufwerke im allgemeinen und hat nicht direkt etwas mit solchen Tools wie XSubst zu tun.

Hier meine Beobachtungen:
  • 1) Egal welches Windows, prinzipiell ist das Handling mit dem Papierkorb dann kein Problem, wenn das Subst-Laufwerk nicht auf das Root (Stammverzeichnis) eines anderen Laufwerkes zeigt. Abgesehen davon macht es eh nicht wirklich Sinn, ein Subst auf das Root eines anderen Laufwerkes zu setzen, da man Substs ja vorrangig einsetzt, um sich die Navigation durch zig Unterverzeichnise zu sparen.
Wenn aber das Subst-Laufwerk auf ein Root gemounted wird, ergeben sich hierdurch einige Probleme bzw. Einschränkungen:
  • 2) Win98 ignoriert in diesem Fall bei zu löschenden Dateien die Einstellung "In den Papierkorb löschen" und löscht direkt! Dies trifft auf das Subst-Laufwerk zu, das "echte" verhält sich wie gewohnt.
  • 3) WinXP und Win2K löschen zwar in den Papierkorb wenn man im Subst-Laufwerk Dateien löscht, diese Dateien sind dann aber nicht über den Papierkorb wiederherstellbar, sondern nur direkt im recycler Verzeichnis. Den ursprünglichen Dateinamen muss man allerdings selbst wieder vergeben, da gelöschte Dateien prinzipiell umbenannt werden.
  • 4) Unter WinXP/Win2K kommt hinzu, dass Punkt 3 auch für Dateien zutrifft, die im "echten" Laufwerk gelöscht werden, solange darauf ein Subst gemounted ist.
Fazit: Windows scheint schlicht nicht dafür ausgelegt zu sein, in dem gleichen recycler Verzeichnis mehrere unterschiedliche Laufwerke zu verwalten. Momentan kann ich also nur abraten, Subst-Laufwerke auf das Root eines anderen Laufwerkes zu setzen. Es sei denn man benötigt den Papierkorb prinzipiell nicht, dann kann dieser Punkt komplett ignoriert werden.

Shell Kontext Erweiterung:
Für Win98/WinME muss das Zusatzmodul xsubstshell.exe im Verzeichnis von XSubst vorhanden sein, dies wird beim Installer immer mit installiert. Unter Win2K/WinXP wird es übrigens nicht benötigt und könnte auch gelöscht werden.

Programmiersprache:
XSubst wurde mit VisualBasic 6 SP6 entwickelt.

Konzept:
XSubst verwendet Techniken, die mit den Bordmitteln von VisualBasic entweder gar nicht oder nur extrem umständlich realisiert werden können. Diese wären:
  • Ermittlung aller vorhandenen Laufwerke und deren Typ sowie Status
  • Konvertierung von langen zu kurzen Dateipfaden und umgekehrt
  • Ermittlung von UNC-Pfaden
  • Subst-Laufwerke anlegen und löschen
  • Spaltenbreite der ListView-Komponente codegesteuert ändern
  • Systemrequester für Ordner-Auswahl inklusive Netzwerkumgebung
  • Ermittlung der Windows Variante sowie Zusatzinfos (Servicepack Stand)
  • Netz-Laufwerke anlegen, löschen, Status ermitteln
  • Verknüpfungen für Laufwerke erzeugen
  • Icon mit Menü im Systray
  • Eintrag in der Taskleiste während der Laufzeit an/ausschalten
  • Codegesteuertes ansprechen des HTML-Help Systems
  • Registry-Behandlung
  • Ermitteln des Windowsusers
  • Ermitteln ob Adminrechte vorhanden sind
  • URL im Browser öffnen
  • Grenzen eines Fensters auf lowlevel-Ebene fixieren.
  • Desktoppfad ermitteln
  • Komplette INI Handhabung
Diese speziellen Techniken wurden über direkte Programmierung der Windows-API gelöst. Auf diese Weise nutze ich sozusagen die Bordmittel von Windows, ohne mit irgendwelchen zusätzlichen externen Komponenten arbeiten zu müssen.

Installer:
Für meine Tools verwende ich NSIS (Nullsoft Scriptable Install System). Das ist eine sehr professionelle und komplexe Installer-Skriptsprache. Es gibt nichts was man damit nicht lösen könnte, erfordert allerdings auch einige Einarbeitung. Was NSIS selbst nicht bietet, wird durch die grosse und durchweg sehr erfahrene Community durch Plugins beigesteuert.


Tweaks

 Tweaks:

Tweaks (am besten mit Kniffe übersetzt) sind Eingriffe in das Verhalten/Konfiguration des Tools. Tweaks sind hier entweder experimenteller Natur, oder aber es handelt sich um Funktionen/Änderungen die nur selten benötigt werden. Darum sind diese nur direkt in der INI oder Registry einstellbar. Prinzipiell werden die Tweaks auf gültige Parameter geprüft. Man kann also nichts eintragen, was völliger Blödsinn wäre. ;)

Globale Tweaks in der zentralen Konfigurationsdatei:
Speicherort: <xsubst ordner>\xsubst.ini

Globale Tweaks dürfen ausschliesslich in der zentralen (globalen) INI stehen und ausschliesslich in der Sektion [GLOBAL]. Stehen sie an anderer Stelle, werden sie ignoriert.

[GLOBAL]

DONTUSEPERSONALINI=0/1 (Standard:0)
Normalerweise werden alle Daten in einer persönlichen Konfigurationsdatei gespeichert. Wird dieser Schalter in der Sektion [GLOBAL] gesetzt, wird nur noch die zentrale INI im XSubst Ordner verwendet. Das ist z.B. dann sinnvoll, wenn XSubst von USB Stick verwendet werden soll. Wenn dieser Tweak aktiv ist, muss natürlich auch gewährleistet sein, dass alle Benutzer Schreibrechte im XSubst Ordner haben. Ansonsten können Konfiguration sowie Laufwerke natürlich nicht gespeichert werden.

DONTUSEPERSONALPROFILE=0/1 (Standard:0)
Per Standard werden die Daten in einer persönlichen Sektion der Konfigurationsdatei gespeichert. Ist dieser Schalter aktiv, werden alle Daten direkt in der globalen Sektion [GLOBAL] verwaltet. Das ist z.B. dann interessant, wenn XSubst von USB Stick verwendet werden soll. Denn in diesem Fall wäre die Benutzerverwaltung eher kontraproduktiv.

Tweaks im persönlichen/globalen Profil:
Speicherort entweder in %userprofile%\anwendungsdaten\luke filewalker productions\xsubst\xsubst.ini oder <xsubst ordner>\xsubst.ini.

Wo diese Tweaks gesetzt werden müssen, ist abhängig ob die globalen Tweaks DONTUSERPERSONALINI und/oder DONTUSEPERSONALPROFILE aktiv sind.

[GLOBAL] oder [<benutzer>]

DONTSHOWBUSYSPLASH=0/1 (Standard:0)
Beim starten von XSubst wird ein kleines, rahmenloses Fenster (Splashscreen) angezeigt mit dem Hinweis das der Status der Laufwerke ermittelt wird. Dies ist besonders in Netzwerken nützlich, in denen Netz-Laufwerke über VPN in ein anderes Netzwerk gemappt sind. Dann dauert es nämlich einige Zeit, bis Windows den Status der Netz-Laufwerke an XSubst weitergeleitet hat. In dieser Zeit sieht es dann so aus, als ob XSubst noch gar nicht geladen ist oder sich beim starten aufgehängt hat. Wer nicht in einer solchen Umgebung arbeitet und gewohnt ist, dass XSubst "fast sofort" geladen und bereit ist, kann diesen Splashscreen mit diesem Tweak auch deaktivieren.

DONTSHOWDRIVELABELS=0/1 (Standard:0)
Normal zeigt XSubst hinter den Laufwerksbuchstaben die Laufwerk-Labels an, also die Namen der Partitionen. Mit diesem Schalter kann dies deaktiviert werden.

SHOWDRIVELABELSAB=0/1 (Standard:0)
Umgekehrt kann mit diesem Schalter die Anzeige für die Laufwerke A und B aktiviert werden. Normalerweise werden A und B nicht abgefragt, da dies immer mit mehr oder weniger störenden und hörbaren Zugriffen auf die Diskettenlaufwerke verbunden ist.


Integration

 Integration in andere Programme:

Durch die Befehle der Shell Kontext Erweiterung (SKE) ist es möglich die Grundfunktionen von XSubst in andere Programme, z.B. Datei Manager, zu integrieren.

Folgende Befehle gibt es:
/SET="<pfad>" (Laufwerk anlegen)
/CUT="<pfad>" (Laufwerk trennen)

Die Pfade können übrigens im Shortpath Format (z.B. C:\DOKUME~1) oder auch im Longpath Format (z.B. C:\Dokumente und Einstellungen) übergeben werden. XSubst verwaltet intern sowieso beide Formate. Und natürlich können ebenfalls UNC Pfade übergeben werden (z.B. \\server1\projekte) um Netz-Laufwerke zu behandeln, ebenfalls im Shortpath oder Longpath Format. Auch ist es unerheblich, ob Pfade einen abschliessenden Backslash enthalten (z.B. C:\Programme\), dieser wird automatisch entfernt. Anführungszeichen können verwendet oder weggelassen werden, diese werden sowieso komplett entfernt.

Total Commander

Hier gibt es gleich mehrere Methoden der Integration:
  • Als Buttons in der Buttonbar
  • Als Menüpunkte im Startermenü
  • Als benutzerdefinierte Befehle (erst ab TC 7 möglich)
Hier wird nur anhand des Startermenüs erklärt wie XSubst integriert werden kann, dies gilt stellvertretend für die anderen Möglichkeiten. In dieser Schritt-für-Schritt Anleitung wird davon ausgegangen, dass XSubst nach C:\Programme\XSubst\ installiert wurde. Pfade müssen also eventuell angepasst werden.

Menü erstellen
Schritt 1: Hauptmenü/Starter/Startermenü ändern... aufrufen
Schritt 2: Untermenü... klicken
Schritt 3: Titel "XSubst" eingeben und bestätigen
Schritt 4: Hinzufügen... klicken (Auswahl muss noch auf "-XSubst" stehen)
Schritt 5: Titel "Laufwerk verbinden..." eingeben und bestätigen
Schritt 6: Hinzufügen... klicken
Schritt 7: Titel "Laufwerk trennen" eingeben und bestätigen

Parameter festlegen
Schritt 8: Bei "Laufwerk verbinden..." folgendes eintragen:
Kommando: C:\Programme\XSubst\XSubst.exe
Parameter: /set="%P%N"
Startpfad: (bleibt leer)
Tastenkürzel: (nach Wunsch festlegen)

Schritt 9: Bei "Laufwerk trennen" folgendes eintragen:
Kommando: C:\Programme\XSubst\XSubst.exe
Parameter: /cut="%P"
Startpfad: (bleibt leer)
Tastenkürzel: (nach Wunsch festlegen)

Hinweis: Unter Win98/WinME muss bei der Funktion "Laufwerk trennen" anstelle xsubst.exe unbedingt xsubstshell.exe eingetragen werden!

Bedienung:
Besonders komfortabel und schnell ist die Bedienung, wenn für beide Funktionen Shortcuts festgelegt wurden. Dann muss noch nicht mal mehr ein Button geklickt oder ein Menüpunkt aufgerufen werden.

Verbinden: Soll auf ein lokales Verzeichnis ein Substlaufwerk oder auf eine Netzwerkfreigabe eine Netz-Laufwerk angelegt werden, muss dieses Verzeichnis oder die Freigabe im TC Fenster ausgewählt sein. Es gilt also hier das Verzeichnis unter dem TC Cursor. Es kann auch eine Datei ausgewählt sein, in diesem Fall wird das Verzeichnis genommen, in dem die Datei steht. Wird nun die Funktion für Verbinden aufgerufen, erscheint ein Kontextmenü in dem mit Maus, Cursortasten+<Enter> oder Buchstabe das gewünschte Laufwerk ausgewählt werden kann. Nachdem dieses ausgewählt wurde, ist das Laufwerk auch bereits vorhanden und aktiv.

Trennen: Um ein Laufwerk wieder zu trennen, muss im Verzeichnisfenster von TC dieses Laufwerk auch gerade angezeigt werden. Hierbei ist es jedoch völlig egal, an welcher Stelle des Verzeichnisbaumes sich das aktuelle Verzeichnisfenster befindet. Nach einer Sicherheitsabfrage (falls aktiviert) wird das Laufwerk wieder dauerhaft entfernt.

Weitere Infos bezüglich TC:
Mit %P übergibt TC den aktuellen Pfad des Quell Verzeichnisses im Longpath Format an XSubst. Mit %p wird übrigens das Shortpath Format verwendet. Mit %N wird der ausgewählte Dateiname (oder Verzeichnisname) im Lonpath Format übergeben und entsprechend mit %n im Shortpath Format.

1. Anpassung für TC: Durch eine spezielle Anpassung an TC ist das Konstrukt %P%N überhaupt erst möglich, d.h. damit kann dann entweder direkt ein Verzeichnis ausgewählt sein, oder eine Datei. Ist eine Datei ausgewählt, ermittelt XSubst automatisch das Verzeichnis in der diese Datei steht.

2. Anpassung für TC: Eine weitere Funktion speziell für TC bezieht sich auf die Übergabe von Netzwerk-Freigaben. Wenn über die Netzwerkumgebung von TC z.B. die Freigabe "\\Peters Supercomputer\C (peter1)" ausgewählt wird, löst TC dies nicht auf und XSubst würde sich weigern, ein Laufwerk darauf einzurichten. Die korrekte Übergabe an XSubst müsste in diesem Beispiel nämlich wie folgt lauten: "\\peter1\c", also mit dem tatsächlichen Computernamen anstatt dem zusammengesetzten Text (Beschreibung)+(Computername). XSubst löst dieses Konstrukt aber ebenfalls auf und erzeugt automatisch einen gültigen UNC Pfad.

XSubst konvertiert also immer so, dass auf jeden Fall ein gültiges und existierendes Verzeichnis ermittelt wird. Ist dies schlussendlich nicht möglich, führt XSubst auch keine Aktion durch.


Hintergrund

 Hintergrund dieses Tools:

Ich suchte ein Tool mit dem ich unter allen Windows-Varianten mit nur einem Tool solche Subst-Laufwerke auf die gleiche Weise einrichten konnte. Jedoch alles was ich fand, entsprach nicht meinen Vorstellungen. Entweder es fehlte die Übersicht und/oder es war zu umständlich in der Bedienung.

Darum ist dieses Tool entstanden, dass gegenüber anderen Tools dieses Typs folgende für mich wichtige Vorteile bietet:
  • Die Handhabung ist unter allen Windows-Versionen gleich.
  • Es zeigt übersichtlich alle Laufwerke auf einmal an.
  • Zusätzlich zeigt es Infos an, um welchen Typ es sich bei dem Laufwerk handelt und mit welchem Pfad es verbunden ist.
  • Bereits substituierte Laufwerke können einfach auf ein anderes Verzeichnis geändert werden, ohne dass das betreffende Laufwerk zuerst getrennt und dann wieder mit dem neuen Pfad verbunden werden muss. Dies geschieht in einem Arbeitsgang.
  • Laufwerke können entweder temporär oder permanent angelegt werden.
  • Subst-Laufwerke werden dem Benutzerprofil zugeordnet.
  • Wird nur dann mit Windows gestartet, wenn mindestens ein permanentes Subst-Laufwerk vorhanden ist.
  • Im Gegensatz zu allen anderen Subst-Alternativen die ich kenne, konzentriert sich XSubst nicht alleine auf Subst-Laufwerke, sondern eher auf die Übersicht aller Windows eigenen Laufwerke, ob "real" oder "virtuell". Bereits das Ur-XSubst wurde nach diesem Konzept entwickelt.


2.2.46 4.12.2007
----------------
* Bugfix: Bez. Änderung des Languagepack Systems in 2.2.45: Falsche Anzeige der
  Folder Sharings innerhalb von VPC.

2.2.45 2.12.2007
----------------
* Bei Subst-Laufwerke wird jetzt konsequent die gleiche Anzeige in der
  Laufwerksliste verwendet wie bei den anderen Laufwerkstypen auch. Also anstatt
  z.B. "Festplatte (Subst)" wird jetzt "Subst-Laufwerk (Festplatte)" angezeigt.
* Änderungen im Languagepack-System wodurch insg. 3 Variablen wegfallen konnten
  und durch 1 ersetzt wurden.
* Routine für die Übersetzung (Languagepack) der Laufwerkstypen robuster
  gestaltet.
* Mit F5 kann nun jederzeit manuell eine Aktualisierung der Laufwerksliste
  ausgelöst werden, ist aber normal nicht nötig. Entspricht im Prinzip dem
  Refresh des Explorers.
* Einige Fehler in der Hilfe korrigiert (vor allem bei den Tweaks) sowie weitere
  Aktualisierungen eingebaut.
* Installer auf NSIS 2.33 aktualisiert.
* Im Installer kann jetzt festgelegt werden, ob Verknüpfungen wie Startmenü-
  Einträge, Desktop-Verknüpfung usw. für alle Benutzer angelegt werden sollen,
  oder nur für den aktuellen Benutzer.

2.2.40 12.10.2007
-----------------
* Bugfix: Beim Umschalten der Sprache wurde der Konfigurations-Fenstertitel
  nicht sofort angepasst.
* 2 neue Tweaks: DONTSHOWDRIVELABELS zum deaktivieren der Laufwerk-Labels und
  SHOWDRIVELABELSAB zum aktivieren der Laufwerk-Labels für Laufwerk A+B.
* Hilfe aktualisiert.

2.2.38 11.10.2007
-----------------
* Bugfix: Bei einem VPC Folder Sharing Laufwerk konnte fälschlicherweise eine
  Änderung des Laufwerks-Buchstaben gestartet werden (Drag&Drop), was natürlich
  fehlschlägt da hier Änderungen von aussen nicht erlaubt sind. Wird jetzt
  verhindert.
* VPC Folder Sharings werden nun auch unter Vista richtig erkannt.
* Da offenbar einige Benutzer (ich selbst auch) XSubst gerne mal so starten um
  sich eine Übersicht der Laufwerke in kompakter Form anzeigen zu lassen,
  entstand der Wunsch auch in XSubst die Laufwerk-Labels sehen zu können. Diese
  werden jetzt mit Ausnahme von A+B hinter dem Laufwerksbuchstaben angezeigt.
  Dafür die Standardbreite von XSubst leicht erhöht.

2.2.36 7.7.2007
---------------
* Bugfix: Durch Mausklicks auf Bereiche ausserhalb der Laufwerksliste
  verabschiedete sich XSubst mit einem Error 9. Der Grund war eine fehlende
  Bereichsabfrage im OLE Drag&Drop. (Hinweis: Icfu)

2.2.35 22.6.2007
----------------
* Meine neue Systrayroutine eingebaut die ab jetzt in alle meine Tools
  integriert wird. Diese etabliert nach einem Crash/Neustart des Explorers
  wieder automatisch das Systrayicon nach spätestens 5 Sek. XSubst konnte zwar
  in diesem Fall mit einem erneuten Aufruf zumindest wieder in den Vordergrund
  gebracht werden, aber besser ist natürlich wenn das Systrayicon automatisch
  wieder angelegt wird. Die Routine ist ausserdem Fehlerbereinigt: Thema 100%
  Last bei Explorercrash. Betraff jedoch XSubst nicht.
* Bei Pfad-Typ 2 (rotation mit Strg+P) wurde bisher bei überlagerten Laufwerken
  nicht der NT- Gerätename/Pfad des aktiven realen Laufwerks angezeigt. Wird
  jetzt konsequenterweise berücksichtigt.
* Bei Pfad-Typ 2 und 3 werden die Gerätenamen/Pfade jetzt ebenfalls in rot
  dargestellt. Das ist konsequenter, da ansonsten die Pfade von Subst- und Netz-
  Laufwerken ja auch entsprechend den Zuständen gefärbt werden.
* Weitere Debuginfos: u.a. die interne Snapshot-Tabelle sowie die sichtbare
  Laufwerks-Tabelle.

2.2.32 27.5.2007
----------------
* Bugfix: Ein überlagertes Laufwerk konnte über die SKE getrennt werden. Wenn
  ein deaktiviertes Subst- oder Netz-Laufwerk gerade von einem USB-Stick
  überlagert war, wurde in diesem Fall nicht nur fälschlicherweise das
  überlagerte deaktivierte Subst- oder Netz-Laufwerk getrennt, sondern auch
  gleich noch der USB-Stick selbst. Das war mehr "Funktionalität" als XSubst
  eig. haben sollte. ;)
* Bugfix: Ein überlagertes Laufwerk konnte per Drag&Drop verschoben werden.

2.2.30 25.5.2007
----------------
* Bugfix: Kleineres Problem bei der Erkennung von überlagerten Netz-Laufwerken
  behoben. Ein solches wird jetzt nur noch dann erkannt, wenn das Netz-Laufwerk
  als "permanent deaktiviert" eingetragen ist.
* Bugfix: Konnte ein deaktiviertes Netz-Laufwerk mit {Aktivieren} nicht
  reaktiviert werden, wurde der Eintrag fälschlicherweise komplett entfernt. War
  natürlich so überhaupt nicht gedacht.
* Bei aktiven Netzlaufwerken in langsamen Netzwerk-Umgebungen wie z.B. über VPN
  kann es recht lange dauern, bis das Hauptfenster von XSubst erscheint. Deshalb
  ein Splashscreen eingebaut der beim Start von XSubst erscheint. Somit sieht
  man sofort das XSubst zwar bereits geladen, aber gerade beschäftigt ist.
  (Vorschlag: B. Jelinek)
* Neuer Tweak DONTSHOWBUSYSPLASH mit dem dieser Splashscreen auch wieder
  deaktiviert werden kann.
* Bei deaktivierten Netz-Laufwerken wurde der UNC-LongPath ermittelt. Das
  kostet nur unnötig Zeit, vor allem in Bezug auf VPN. Daher wird dieser jetzt
  nur noch bei aktiven Netz-Laufwerken ermittelt, denn nur da ist das wichtig.
* Damit jederzeit klar ist ob XSubst gerade beschäftigt ist, eine LED über den
  Buttons eingebaut mit den Farben Grün und Rot. Ausserdem wird der Cursor
  geändert wenn XSubst beschäftigt ist (Sanduhr). Somit ist der Benutzer nun
  jederzeit informiert ob XSubst gerade beschäftigt ist - und sich nicht
  aufgehängt hat. ;)
* In der Statusleiste wird jetzt zusätzlich angezeigt, ob die Benutzer-bezogene
  oder die globale INI verwendet wird. Damit sind nun die wichtigsten Infos
  sofort ersichtlich, ohne die Debuginfos aufrufen zu müssen.
* Weitere Debuginfos hinzugefügt und neu strukturiert. Ausserdem wird jetzt der
  Inhalt der aktiven INI angehängt. So hat man im Problemfall sämtliche
  Informationen komplett und muss nicht erst noch auf die Suche nach der INI
  gehen.
* Neue Languagepacks.
* Installer auf NSIS 2.27 aktualisiert.

2.2.15 26.4.2007
----------------
* Bugfix: Optisches Problem behoben. Bei unterschiedlichen Windows Themen
  (Styles) kann es auch unterschiedliche OuterWidth Werte des Hauptfensters
  geben. Deshalb kam es u.U. zu falscher Positionierung der Buttons und falscher
  Breite der Laufwerks-Liste.

2.2.14 11.4.2007
----------------
* Bugfix: Bei deaktivierten Warn-Hinweisen und einem inaktiven Netz-Laufwerk
  wurde fälschlicherweise der Button Temporär/Permanent rot unterlegt. (War eig.
  mehr ein optisches Problem als ein echter Bug.)
* Die Funktion {Permanent deaktivieren} wird bei Subst-Laufwerken jetzt
  gesperrt, wenn XSubst nicht lokal installiert wurde. Diesen Punkt habe ich
  bisher schlicht übersehen in der Routine für "Abhängigkeitslogik" die dafür
  sorgt, dass keine unsinnigen Aktionen durchgeführt werden können.
* Die Funktionen {Permanent deaktivieren} und {Aktivieren} stehen nun auch für
  Netz-Laufwerke zur Verfügung. Weiterhin kann nun auch der Pfad eines
  deaktivierten Netz-Laufwerkes geändert werden. Damit stehen nun fast alle
  Funktionen für beide Laufwerkstypen gleichermassen zur Verfügung, lediglich
  {Temporär deaktivieren} bleibt den Subst-Laufwerken vorbehalten.
* LED eines überlagerten Laufwerks von Orange auf Dunkelblau geändert. Das ist
  ein Stück weit logischer da es sich in diesem Fall primär um ein "System-
  Laufwerk" handelt und System-Laufwerke haben ja sonst die Farbe Aqua
  (Hellblau).
* Weitere Debuginfos hinzugefügt.

2.2.1 3.4.2007
--------------
* Bugfix: Unter bisher nicht geklärten Umständen kann es unter Win 98 zu einem
  optischen Problem bei der Anzeige der Laufwerksliste kommen. Dies hängt in
  irgendeiner Form mit der codetechnischen Ansteuerung der Schrift und der
  Schriftgrösse zusammen. Diese Ansteuerung wieder entfernt, da sie nicht
  zwingend notwendig ist. Bekannt ist mir das "Phänomen" jedoch nur von einem
  Benutzer. ("Ted West Bug", greetings to Phoenix/Arizona. ;-) )
* Onlinehelp English hinzugefügt mit Übersetzung der wichtigsten Kapitel.
  (Übersetzer: DBH64)
* Installer auf NSIS 2.25 aktualisiert.

2.2 25.3.2007
-------------
* RELEASE
* BETA Bugfix: Bei nicht vorhandener INI wurden auch keine Standardwerte
  gesetzt, war natürlich total sinnfrei.
* Languagepacks werden nicht mehr umständlich von XSubst kopiert, sondern
  direkt aus dem Ordner "languages" gelesen. Die Datei xsubst.lng bzw.
  xsubstlanguage.ini im XSubst Ordner ist somit hinfällig.
* Das gleiche gilt für die Online HTML Hilfedateien, diese werden jetzt direkt
  aus dem Ordner "helpfiles" gelesen.
* Weiterhin wird beim Umschalten der Sprache das Languagepack sofort geladen.
  Ein Neustart von XSubst ist nicht mehr notwendig. Gleiches gilt für das
  Helpfile.
* Die eingestellte Sprache wird jetzt Benutzerabhängig gespeichert.
* Ist beim Start keine INI vorhanden, wird automatisch die Konfiguration
  aufgerufen mit dem Karteireiter der Sprachwahl. Dies ist primär für die Zip-
  Variante gedacht um auch damit schnell und direkt eine Sprache auswählen zu
  können. Das ist ein Kompromiss der auf einem Vorschlag von Christian Ghisler
  beruht.
* In Bezug auf echte Multiuser Umgebungen und als Vorbereitung auf Vista wurde
  jetzt die Verwaltung konsequent auf persönliche INI's umgestellt. Statt einer
  zentralen INI hat also nun jeder User seine eigene die unter
  %userprofile%\anwendungsdaten\luke filewalker productions\xsubst zu finden
  ist. Die Verwaltung funktioniert genauso unter 9x, sofern die
  Benutzerverwaltung dort aktiviert wurde. Bei PC's mit nur einem Benutzer bzw.
  wenn es nur Adminuser gibt, kann optional auf zentrale INI wie bisher
  umgestellt werden. (Siehe Onlinehilfe:Anhang/Tweaks)
* 2 neue Tweaks für die INI Verwaltung.
* Das Debugfenster kann jetzt beliebig in der Grösse verändert werden.
  Zusätzliche Infos wie z.B. die primäre interne Laufwerks-Tabelle.
* Installer auf NSIS 2.24 aktualisiert.
* Sowohl Installer wie auch xsubst.exe prüfen direkt beim Start die Windows
  Variante. Im Fall von Windows 95 werden beide Programme sofort beendet.
* Languagepack Francais hinzugefügt. (Übersetzer: Fonetix)

2.1.32 BETA 2.2 20.3.2007
-------------------------
* Bugfix: Bei INI-Verwaltung konnte es vorkommen, dass XSubst nicht automatisch
  mit Windows gestartet wurde, obwohl ein permanentes Laufwerk vorhanden war. In
  der INI Routine fehlte schlicht ein Registry-Befehl. Dieser Bug dürfte jedoch
  nur bei ganz frischen Windows-Installationen auftauchen, bei denen der
  entsprechende Registry-Pfad (Run) noch fehlt.
* Über die LED's kann nun auch der besondere Zustand eines überlagerten Subst-
  Laufwerkes signalisiert werden. Also ein deaktiviertes Subst-Laufwerk dessen
  Laufwerksbuchstabe gerade von einem Wechseldatenträger verwendet wird.
* In der Konfiguration/Sprachauswahl wird die aktuell eingestellte Sprache
  angezeigt, sofern diese auch als Languagepack existiert. (Vorschlag: Fonetix)
* Meine neue INI-Library eingebaut die mit der Standard INI-API arbeitet. Diese
  ersetzt meine bisherigen INI-Routinen. Dadurch ergeben sich mehrere
  Verbesserungen/Änderungen:
  1) Die Handhabung der INI-Dateien ist codetechnisch nun deutlich einfacher,
  gerade wenn eine INI aus mehreren Sektionen besteht wie bei XSubst. Die
  Endmarkierungen [USER.END] sind jetzt übrigens überflüssig und könnten aus der
  INI gelöscht werden.
  2) Durch meine neue Library sind INI- Dateien zukünftig nicht mehr nur
  abwärts- sondern prinzipiell auch aufwärts- kompatibel.
  3) Manuelle Änderungen können nun bedeutend robuster und transparenter
  gehandhabt werden. So ist es jetzt z.B. problemlos möglich eigene Kommentare
  einzubauen (mit führendem ; ) die auch erhalten bleiben.
  4) Ich muss mich nicht mehr selbst um die Zugriffsberechtigungen (Thema Timing
  Problem) der INI kümmern, das erledigt die API schon selbst.
  5) Nachteile sind jedoch das ich keinen direkten Einflus mehr auf die
  Reihenfolge der Einträge habe und das die Library messbar langsamer ist als
  meine direkte Routine.
* Aufgrund der nun erheblich komfortableren INI Handhabung habe ich mich dazu
  entschlossen die Registry-Unterstützung komplett über Board zu werfen.
  Sämtliche Routinen für die Datenspeicherung in der Registry wurden entfernt.
  Damit ist XSubst wieder ein reines INI Tool und nur noch die technisch
  absolut unvermeidbaren Registry Zugriffe sind übrig geblieben.
* Weitere Code Optimierungen.

2.1.13 BETA 2.2 13.3.2007
-------------------------
* Bugfix: In der Konfig konnte es bez. der Sprachauswahl zu einem error 52
  kommen, ist mir jedoch nur von einem Benutzer bekannt. (Hinweis: Fonetix)
* Es werden nun auch die virtuellen Netz-Laufwerke (MS folder sharings) in
  VPC erkannt, ab Gastbetriebssystem Win98. Bei diesen Laufwerken werden dann
  sämtliche Funktionen ausser Verknüpfungen gesperrt und Laufwerk/Ordner der
  Freigabe angezeigt. Getestet mit VPC 2004 & 2007.
* Multilanguage Support für Onlinehilfe. Wenn es zu einer Sprache neben dem
  Languagepack auch eine entsprechende Übersetzung der Onlinehilfe gibt, wird
  diese berücksichtigt.
* In der Spalte Pfad wird jetzt in Klammern der aktuelle Pfad-Typ (2 oder 3)
  angezeigt, wenn dieser von der Normalanzeige 1 abweicht.
* Languagepacks haben jetzt die Suffix .lng und im XSubst Ordner heisst das
  Languagepack einfach xsubst.lng
* Kleinere Code Optimierungen.
* Eine optional einblendbare LED-Leiste zeigt an, in welchem Zustand sich die
  von XSubst verwaltbaren Laufwerke befinden. Die LED's stammen von twiki.org.
  (Mit freundlicher Genehmigung von Arthur Clemens und Peter Thoeny)

2.1.5 20.12.2006
----------------
* Genauso einfach wie der Pfad eines Subst- oder Netz-Laufwerkes geändert
  werden kann, ist es nun auch möglich das Laufwerk zu ändern. Mit Drag&Drop in
  der Laufwerksliste lässt sich ein Pfad auf einen anderes, freies Laufwerk
  "verschieben".
* Mit Strg+P lassen sich jetzt anstelle der normalen Pfade auch die Windows
  internen Gerätenamen und Pfade anzeigen. Entweder für alle ausser Subst- und
  Netz-Laufwerke oder für alle. Im Prinzip nicht wirklich wichtig, zeigt einfach
  nur wie Windows selbst die Laufwerke intern verwaltet. Nur für Windows
  Varianten mit NT Kernel.
* In der Statusbar wird jetzt auch immer aktuell angezeigt, ob der volle
  Funktionsumfang gegeben ist. Hierfür 3 neue Sprachvariablen angelegt.

2.1 5.12.2006
-------------
* RELEASE
* SKE: Konvertierung des Konstrukts (Beschreibung)+(Computername) robuster
  gestaltet.
* Sprachvariable author_version hinzugefügt, damit der Autor des jeweiligen
  Languagepacks kennzeichnen kann, für welche XSubst Version es geschrieben
  wurde.

2.0.26 BETA 2.1 4.12.2006
-------------------------
* SKE: Bei Netzwerk-Freigaben die von TC übergeben werden, wird jetzt das
  Konstrukt (Beschreibung)+(Computername) in einen gültigen UNC Pfad gewandelt.
* SKE: Sind keine verfügbaren Laufwerksbuchstaben mehr frei, wird dies nun auch
  gemeldet.
* Die Einstellung "Warnhinweise bei Trennungen" ist nun separat für GUI und SKE
  verfügbar.

2.0.14 BETA 2.1 2.12.2006
-------------------------
* SKE: Mehr ein Schönheitsfehler als ein Bug: Wurde über die SKE ein Netz-
  Laufwerk eingerichtet, übernahm er nur den Shortpath in die Laufwerksliste,
  ebenso in den Tooltip der Desktopverknüpfung. Auch hier wird jetzt konsequent
  der LongPath verwendet.
* SKE: Jetzt ist es auch möglich Netz-Laufwerke zu trennen.
* SKE: Für TC weiter überarbeitet. Jetzt kann z.B. auch der Aufruf /set="%P%N"
  verwendet werden, um das Verzeichnis unter dem Cursor mit einem Subst- oder
  Netz-Laufwerk zu verbinden. Damit muss nicht mehr ins Verzeichnis gewechselt
  werden vor dem verbinden. Wird mit dem Aufruf kein Verzeichnis sondern eine
  Datei übergeben, wird automatisch der Pfad dieser Datei ermittelt.

2.0.10 BETA 2.1 1.12.2006
-------------------------
* Bugfix: Wurde über SKE ein Netz-Laufwerk eingerichtet und die Option für
  automatische Desktopverknüpfung war aktiv, übernahm er nicht den Netzwerk-Pfad
  in den Tooltip, sondern nur den Laufwerksbuchstaben.
* SKE: Für externe Aufrufe, wie z.B. über Total Commander, überarbeitet und
  rudimentäre Kontroll- und Konvertier-Routinen eingebaut.
* SKE: Nun können auch problemlos Netz-Laufwerke über TC eingerichtet werden.
  Schuld war ein \ am Ende des von TC übergebenen Pfades.
* Subst- und Netz-Laufwerke können nun getrennt nach GUI und SKE konfiguriert
  werden.
* Konfiguration neu gruppiert und auf Registerkarten verteilt.
* Win Vista wird nun auch erkannt, dies ist aber z.Z. noch nicht wichtig.

2.0 2.11.2006
-------------
* RELEASE

1.6.102 BETA 2.0 RC2 30.10.2006
-------------------------------
* BETA Bugfix: Sprachvariable für listdriveunknown wurde nicht aufgelöst.
* Debug Fenster aus Menü genommen, dies kann jetzt mit Strg+D im Hauptfenster
  aufgerufen werden. So oft braucht man das (hoffentlich) nicht, dass sich ein
  eigener Menüpunkt dafür rechtfertigen würde.
* Weitere Debuginfos hinzugefügt.
* Echte Laufwerke haben in der Anzeige nun Priorität über Subst-Laufwerke: Wird
  auf den Laufwerksbuchstaben eines deaktivierten Subst-Laufwerkes z.B. ein
  Wechseldatenräger wie Platte oder USB-Stick angemeldet, wird dieser
  Datenträger nun auch entsprechend angezeigt und verwaltet. Das Subst-
  Laufwerk wird intern weiterhin verwaltet und steht wieder zur Verfügung,
  sobald der echte Datenträger abgemeldet wurde. Das ist ebenfalls eine Sache
  die ich schon lange einbauen wollte, mich aber bisher vor dem Aufwand gedrückt
  habe. ;)

1.6.99 BETA 2.0 RC2 28.10.2006
------------------------------
* BETA Bugfix: Error 70 Problem - Zugriff verweigert. Durch die neue INI
  Verwaltung konnte es u.U. vorkommen, dass zwei XSubst Prozesse gleichzeitig
  auf die INI zugreifen wollten. Dies konnte dann geschehen, wenn XSubst bereits
  gestartet war (aber nicht minimiert) und gleichzeitig über Shell Kontext ein
  Laufwerk eingerichtet oder gelöscht wurde.
* Beim Benutzernamen wird nicht mehr zwischen Gross/Kleinschreibung
  unterschieden. Wichtig für INI-Verwaltung.
* Sprachvariable für Shell Kontext Submenü "Verbinden" hinzugefügt.
* Bei den Shell Sprachvariablen den String "XSubst - " entfernt, da dieser von
  XSubst selbst vorgegeben werden muss.
* Für Shell Kontext zwei neue Registry Einträge eingebaut um dieses unabhängig
  vom Languagepack auch wieder sauber deaktivieren zu können. Das gleiche gilt
  beim Uninstaller

1.6.75 BETA 2.0 RC1 27.10.2006
------------------------------
* Es wird nun beim Start global überprüft ob XSubst bereits vorhanden ist, statt
  wie bisher die Prüfung nur auf das Verzeichnis zu beschränken, aus dem XSubst
  gestartet wurde. Weiterhin wird nun in diesem Fall der bereits laufende
  XSubst-Prozess in den Vordergrund geholt, anstatt eine Meldung anzuzeigen das
  XSubst bereits läuft.

1.6.69 BETA 2.0 RC1 26.10.2006
------------------------------
* BETA Bugfix: Durch eine falsche Priorität beim Umwandeln der Sprachvariablen
  wurde main_listdriveremoteinactive nicht korrekt aufgelöst.
* Die Routine zum Überprüfen auf Laufwerksänderungen sowie die Routine zur
  Aktualisierung der Liste werden jetzt nur noch aufgerufen, wenn XSubst nicht
  minimiert ist. Was man nicht sieht, braucht nicht aktualisiert zu werden und
  damit ist ein minimiertes XSubst wieder so genügsam was Rechnezeit angeht wie
  immer.

1.6.65 BETA 2.0 RC1 25.10.2006
------------------------------
* BETA Bugfix: Bei jeder Änderung in der Konfig wurde der Sprach-Auswahlbox der
  Eintrag <select language> hinzugefügt sowie alle vorhandenen Languagepacks.
  Dadurch wurde die Liste bei jeder Änderung immer länger.
* Per Option kann nun festgelegt werden, ob XSubst beim Start auf
  Bildschirmmitte zentriert wird, oder von der letzten Position startet.
  (Vorschlag: Icfu)

1.6.58 BETA 2.0 24.10.2006
--------------------------
* BETA Bugfix: Anzeigefehler bei Verwendung der Option "Fensterbreite änderbar"
  korrigiert.
* Alle Unterfenster (z.B. Konfig-Fenster, Hinweis usw.) können jetzt alternativ
  mit ESC geschlossen werden. (Vorschlag: Icfu)
* Die Meldung nach Sprachänderung kommt jetzt erst beim schliessen des Konfig-
  Fensters.

1.6.51 BETA 2.0 23.10.2006
--------------------------
* In der Konfiguration kann nun durch einfaches Auswählen das gewünschte
  Language Pack automatisch kopiert und umbenannt werden, so das dies vom
  Benutzer nicht mehr manuell gemacht werden muss.

1.6.47 BETA 2.0 23.10.2006
--------------------------
* Hinweise werden jetzt erst angezeigt, wenn das Laden von XSubst komplett
  beendet ist. (Vorschlag: Icfu)
* Hinweisfenster etwas grösser gestaltet. (Vorschlag: Icfu)
* Sprachvariablen config_chkperm und config_chkpermlink nach Subst und Netz
  getrennt um Tastatur-Shortcuts dafür definieren zu können.
* Refreshcode (für Button Aktualisieren) komplett entfernt.
* Sprachvariablen für Menü geändert. Dadurch kann nun auch dem Hilfe-Hauptmenü
  ein Name und damit auch ein Shortcut zugewiesen werden.
* Systray Option von "Im Systray einrichten, falls mit Windows gestartet" und
  "Prinzipiell mit Windows starten" abgekoppelt, kann also jetzt unabhängig
  eingestellt werden. Diese beiden Optionen heissen jetzt auch anders.
  (Vorschlag: Icfu)
* Languagepack English hinzugefügt. (Übersetzer: Icfu)

1.6.27 BETA 2.0 22.10.2006
--------------------------
* BETA Bugfix: Die Sprachvariablen für das Systray-Menü waren intern zwar
  deklariert, wurden aber nicht aus dem Language Pack gelesen.
* BETA Bugfix: Es fehlte noch die Sprachvariable für den Link-Kommentar.
* Button {Aktualisieren} entfernt. Dieser ist nicht länger notwendig, da nun
  ständig überprüft wird ob externe Änderungen bei den Laufwerken statt
  fanden.
* Viele kleine interne Optimierungen.

1.6.21 BETA 2.0 21.10.2006
--------------------------
* Bugfix: Wurde beim aktivieren eines deaktivierten Subst-Laufwerkes ein Fehler
  festgestellt, dann wurde zwar eine Fehlermeldung angezeigt, aber trotzdem das
  Laufwerk als aktiv eingetragen.
* Vor Aktivierung/Deaktivierung der Shell Kontext Erweiterung wird erstmal
  überprüft, ob der aktuelle Benutzer überhaupt Administratorrechte hat.
* Kompletten Source auf Multilanguage umgestellt. Über Sprachdateien kann XSubst
  nun in fast jede beliebige Sprache übersetzt werden, die auf dem lateinischen
  Alphabet aufgebaut ist.

1.6.08 BETA 2.0 18.10.2006
--------------------------
* Die Speicherung der Konfiguration/Daten erfolgt nun per Standard für alle
  Benutzerprofile in einer zentralen INI (XSUBST.INI) anstatt in der User-
  Registry. Über einen Tweak ist es denoch möglich stattdessen die Registry-
  Verwaltung zu verwenden.
* Neuer Tweak: REGISTRY. Steht dieses Wort alleine in der ersten Zeile der
  XSUBST.INI, wird statt der zentralen INI die User Registry zum verwalten der
  Konfiguration/Daten verwendet.
* Die Option "Deaktivierte Subst-Laufwerke bleiben permanent deaktiviert" wurde
  entfernt und stattdessen ein neuer Button dafür eingebaut. Der bisherige
  Button deaktiviert nun prinzipiell temporär und der neue Button prinzipiell
  permanent.
* Konfiguration neu strukturiert um Benutzerbezogene und globale Einstellungen
  zu trennen.
* Die neue Statusbar im Hauptfenster gibt nun Auskunft über den aktuellen
  Benutzer, ob Die Daten in der INI oder Registry verwaltet werden und ob XSubst
  beim Windowsstart geladen wird.
* Hilfemenü neu strukturiert. Infos und Debuginfos nun getrennt.

1.6 17.8.2006
--------------
* XSubst bietet nun eine optionale Shell Kontext Erweiterung. Damit können
  Subst-Laufwerke auch direkt über den Arbeitsplatz/Explorer verbunden und
  getrennt werden. Benötigt Adminrechte zur Aktivierung bzw. Deaktivierung.
* Hinweissystem eingebaut um bei manchen Funktionen wichtige Infos anzeigen zu
  können. Die Hinweise lassen sich jeweils einzeln deaktivieren.
* Der Requester bez. nicht-lokale-Installation wurde in die Hinweise
  aufgenommen. Damit hat der Tweak "dontshowlocalwarning" keine Bedeutung mehr
  und wurde entfernt.
* Befindet sich XSubst nicht auf einer lokalen Platte, werden jetzt
  konsequenterweise auch diejenigen Optionen in der Konfig gesperrt, die dann
  sowieso keine Auswirkungen hätten.
* Infofenster (?/Info) um Webseitenlink und Debuginfos erweitert. Die Debuginfos
  geben über einige wichtige Parameter Auskunft ohne REGEDIT bemühen zu müssen.
  Das ist nützlich bei Problemen.
* Ansonsten gab es etliche kleinere interne Verbesserungen.
* Änderungen am Installer: 1) Gesperrte Dateien, z.B. wenn sie bei der
  Installation noch geöffnet sind, können nicht mehr übersprungen werden. Das
  wäre auch sehr unsinnig. 2) Auch das Setup identifiziert sich nun über einen
  eigenen Versions-Tab wenn man die Eigenschaften der Datei anzeigen lässt.

1.5.10 25.6.2006
----------------
* Bugfix: In manchen Situationen blieb die Trennung eines Subst-Laufwerkes
  erfolglos.
* Bugfix: Gleicher Fehler konnte auch beim Deaktivieren auftreten.
* Neue Option: Bei deaktivierten Subst-Laufwerken kann nun festgelegt werden,
  ob diese permanent deaktiviert bleiben sollen.
* Neue Option: Normalerweise wird XSubst beim Windowsstart beendet, nachdem
  die Subst-Laufwerke eingerichtet wurden. Nun lässt sich festlegen, ob XSubst
  in diesem Fall dauerhaft im Systray angelegt werden soll oder nicht.
* Neue Option: Per Standard wird XSubst nur dann mit Windows gestartet, wenn
  es mindestens ein aktives Subst-Laufwerk gibt. Nun kann XSubst auch
  prinzipiell immer gestartet werden.
* Konfig neu gruppiert.

1.5.6 9.4.2006
--------------
* Im Kommentar einer Verknüpfung wird nun auch bei anderen Laufwerken ausser
  Subst und Netz-Laufwerken der Pfad (das Laufwerk um genau zu sein)
  eingetragen.
* Verhalten des Kontextmenüs im Trayicon geändert. Dadurch schliesst sich das
  Menü jetzt automatisch, sobald es den Fokus verliert. Ist eig. eh Standard.

1.5.5 24.3.2006
---------------
* Bugfix: Wurde der Pfad eines permanenten Subst-Laufwerks geändert, dann
  deaktiviert und wieder aktiviert, wurde das Laufwerk wieder mit dem
  ursprünglichen Pfad verbunden.
* Bugfix: Button Aktivieren/Deaktivieren blieb nach dem umschalten von
  deaktivierten Warnhinweisen zu aktivierten fälschlicherweise permanent rot,
  wenn der Listen-Cursor zu diesem Zeitpunkt auf einem aktivierten Subst-
  Laufwerk stand.
* Bugfix: Funktion {Ändern} prüfte nicht, ob Ziel bereits ein Subst- oder
  Netzlaufwerk ist.
* Bugfix: Der Verknüpfungs-Button konnte auch auf ein deaktiviertes und damit
  nicht existentes Subst-Laufwerk angewandt werden.
* Registry Zugriffe in der Run Gruppe werden nun konsequent unterbunden, wenn
  XSubst nicht lokal installiert ist. Damit werden eventuelle Änderungen am
  Startverhalten von XSubst bez. Windows-Neustart verhindert.
* Ein deaktiviertes Subst-Laufwerk bleibt nun nach einer Pfadänderung
  konsequenterweise weiterhin deaktiviert.
* Wurde bei deaktivierten Warnhinweisen ein Subst-Laufwerk deaktiviert, waren
  anschliessend die Buttons für Ändern sowie Trennen rot unterlegt und bei
  aktivierten Warnhinweisen gab es alternativ dazu einen Warnrequester. Da das
  Warnsystem jedoch nur bei tatsächlichen Laufwerks-Trennungen aktiv werden
  soll, bleiben die beiden Buttons in diesem Fall jetzt konsequenterweise ohne
  Warnungen.
* Verzeichnis-Requester enthält nun Angaben über den Modus (Verbinden/Ändern)
  und das Laufwerk.
* Pfadangaben werden nun auch bei inaktiven Laufwerken im LongPath Format
  angezeigt.
* Kann mit Ändern oder Aktivieren kein Subst-Laufwerk eingerichtet werden, wird
  automatisch wieder der vorherige Zustand des Laufwerkes hergestellt.
* Tab-Reihenfolge der Buttons korrigiert.
* Für unbekannte Laufwerkstypen wurde der Typ "Unbekannt" hinzugefügt.
* Desktop-Verknüpfungen enthalten nun im Kommentar zusätzlich den Pfad mit dem
  das Laufwerk verbunden ist.
* Hilfe erweitert.

1.5 16.3.2006
-------------
* RELEASE
* Ob Gitterlinien angezeigt werden oder nicht, ist jetzt wählbar.
* Da Windows XP die Möglichkeit bietet inaktive Trayicons auszublenden, ist
  die Angabe der Versionsnummer im Tooltip des Trayicons eher hinderlich und
  wurde deshalb rausgenommen.

1.0.108 BETA 1.5 3.3.2006
-------------------------
* Funktionen {Neu Verbinden} und {Temp. trennen} zu {Aktivieren} und
  {Deaktivieren} auf einem Button zusammengefasst. Weiterhin {Verbinden}
  und {Ändern} auf einem Button zusammengefasst. Das spart insgesamt wieder
  einen Button. (Vorschlag: Icfu)
* Per Konfiguration kann nun die Fensterbreite, sowie die Reihenfolge der
  Spalten änderbar geschaltet werden. Reihenfolge, Spaltenbreite sowie
  Fensterbreite werden dann dauerhaft gespeichert. Dies beruht auf dem Vorschlag
  von Icfu, die Spalten anders anzuordnen. Da ich die Reihenfolge jedoch nicht
  fest ändern wollte, hab ich das ganze nun völlig flexibel ausgelegt.
* Gitterlinien in Liste aktiviert. Das ist optisch angenehmer.

1.0.98 BETA 1.5 28.2.2006
-------------------------
* Bugfix: Wurde XSubst von einem Wechseldatenträger gestartet, wurde zwar der
  Warn-Hinweis eingeblendet und Funktionen gesperrt, aber trotzdem der aktuelle
  Pfad in die Registry (Run) eingetragen.
* Neue Funktion: {Temp. trennen}. Damit lässt sich ein permanentes Subst-
  Laufwerk vorrübergehend (temporär) trennen.
* Funktionen {Verbinden} und {Neu Verbinden} zu einer Funktion zusammengefasst.
  Bei näherer Betrachtung machten zwei Buttons definitv keinen Sinn.
* Onlinehilfe überarbeitet.

1.0.89 BETA 1.5 25.2.2006
-------------------------
* Onlinehilfe geschrieben.
* HTMLHelp-System eingebaut.
* Menü geändert.

1.0.87 BETA 1.5 24.2.2006
-------------------------
* Kann jetzt wahlweise auch in Systray minimiert werden. (Vorschlag: gresti)

1.0.85 BETA 1.5 24.2.2006
-------------------------
* Bugfix: Wurde ein permanentes Subst-Laufwerk in ein Netz-Laufwerk geändert,
  wurde fälschlicherweise ein inaktives Subst-Laufwerk erkannt und auch so
  behandelt. Tatsächlich war es aber bereits ein Netz-Laufwerk.
* Bugfix: Der Verknüpfungs-Button konnte auch bei nicht vorhandenen Laufwerken
  angewandt werden. Das ist natürlich Nonsens, vor allem da Windows dann auch
  gar nicht wusste, was es für einen System-Link anlegen soll und deshalb
  einfach einen Text-Link erzeugte.
* XSubst kann nun auch minimiert werden.
* Inaktive aber als permament angelegte Subst-Laufwerke können nun per Button
  wieder neu verbunden werden. Hilfreich, wenn ein Subst-Laufwerk beim Windows-
  Start auf einen nicht vorhandenen Wechseldatenträger wie z.B. USB-Platte
  gemounted werden soll, aber dieser zu diesem Zeitpunkt nicht eingelegt bzw.
  angemeldet ist. (Vorschlag: gresti)

1.0.82 BETA 1.5 22.2.2006
-------------------------
* Bugfix: Wurde {Trennen} gewählt und dann aber abgebrochen, wurden nicht wieder
  alle Buttons freigegeben. Change-Button wurde ausserdem gar nicht
  berücksichtigt.
* Zu allen Laufwerken können nun auch direkte Verknüpfungen auf dem Desktop
  angelegt werden. (Vorschlag: gresti) Optional können zu neuen Laufwerken auch
  automatisch Verknüpfungen angelegt werden, wenn diese standardmässig auf
  permanent gestellt sind.

1.0.80 BETA 1.5 21.2.2006
-------------------------
* Die Ermittlung um welches Windows es sich handelt, erfolgt nun über API-
  Aufrufe anstatt Registry. Das ist zum einen sehr viel präziser und zum anderen
  gäbe es dadurch die Möglichkeit, jedes Windows getrennt zu behandeln wenn
  nötig. Zur Zeit reicht jedoch die Abfrage ob NT-Kernel oder nicht.
* Es werden nun auch die Pfade von temporären Netz-Laufwerken ermittelt. Dies
  war bisher nur bei permanenten der Fall.
* Parallel zu Subst-Laufwerken, gibt es nun auch bei Netz-Laufwerken die Angabe
  ob temporär oder pemanent.
* Unterstützung für Netzlaufwerke eingebaut. Diese werden exakt wie Subst-
  Laufwerke behandelt mit den gleichen Funktionen. Damit ist die Bedienung
  bezüglich beider Laufwerks-Typen identisch.
* Es gibt nun Warnhinweise oder aber rot gefärbte Buttons (umschaltbar). Dieses
  System dient als Warnung um Datenverlust vorzubeugen, wenn bei bestimmten
  Funktionen das jeweilige Laufwerk getrennt werden muss.
* Mit XSubst konnte man verschachtelte Subst-Laufwerke anlegen. Das gleiche
  würde ab dieser Version auch mit Netz-Laufwerken gehen. Um Chaos zu
  vermeiden, wird eine solche Verschachtelung nun prinzipiell verhindert.
* Es wird nun beim Start geprüft, ob sich XSubst auf einer festen lokalen
  Festplatte befindet oder nicht. Je nachdem werden dann Funktionen gesperrt die
  nicht möglich sind, wenn XSubst z.B. von einem USB-Stick aufgerufen wird. Der
  Warnhinweis selbst ist über einen Registry Tweak abschaltbar.
* Kleines Menü eingebaut.
* Infofenster eingebaut.
* Konfiguration eingebaut um auf einige Dinge Einfluss nehmen zu können.
* Es kann nun festgelegt werden, ob Subst-Laufwerke standardmässig auf permanent
  gesetzt werden oder nicht. Gleiches gilt für Netz-Laufwerke.
* Es werden nun zu etlichen Aktionen entsprechende Fehlermeldungen ausgegeben,
  falls nicht erfolgreich. XSubst ist also etwas gesprächiger geworden. *g*
* Fast der gesamte Sourcecode wurde umgekrempelt und optimiert. Ausser der GUI
  hat diese Version nicht mehr viel mit 1.0.63 gemeinsam. u.a. habe ich meine
  Registry-Library völlig neu geschrieben und um neue Funktionen erweitert.
* Speicherung der Subst-Daten und der erstmals verfügbaren Konfiguration,
  erfolgt nun konsequent in der Registry (USER). Dies hat etliche Vorteile: Zum
  einen wird dadurch eine konsequente Benutzerverwaltung möglich, die
  theoretisch nun auch unter 9x funktionieren müsste (sofern dort aktiviert).
  Weiterhin gibt es keine Probleme mit eventuell fehlenden Rechten (durch einen
  Admin festgelegt). Ausserdem kann der Standort der xsubst.exe nun beliebig
  verändert werden, da die globale Registry herangezogen wird, statt lokaler
  INI. Nach dem ändern des Installationspfades der .exe muss diese nur einmalig
  kurz aufgerufen werden.

1.0.63 10.10.2005
-----------------
* Umstellung von ZIP auf NSIS Installer.

1.0.63 23.8.2005
----------------
* Erste öffentliche Version

1.0.0 (2003)
-----------------
* Genaue Angaben nicht möglich, da XSubst lange Zeit ein rein internes Tool war.

XSubst © by Luke Filewalker
[EOFCAC]